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Sergei Prokhnevskiy is a Charlotte, NC based motion graphics designer, 
an online tutor, and an entrepreneur. 

Sergei and his twin brother Vladimir run an online educational site 
called ukramedia.com. Sergei is known for his quick and practical After 
Effects tips and tricks on YouTube (ukramedia), where he generated 
well over 5 million views on his tutorials. 

He has authored online video courses and developed tools for After 
Effects. He is also a former senior motion graphics designer at Fox 
Sports where he worked on graphics for NFL, Super Bowl, MLB, World 
Series, College Football, NASCAR, Women’s World Cup, and NASCAR 
Race Hub. Sergei is very passionate about learning and teaching others.

ABOUT THE INSTRUCTOR
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AFTER EFFECTS 
BASICS
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Before we dive deep into After Effects, let’s take the time and 
quickly go over the layout to get familiar with where things are. 

The main basic elements in the interface are:
1. Application Window
2. Toolbar panel: This is where all the tools are stored.
3. Project panel: Contains references to all the footage files 

(video, audio, and images) that we import into After Effects 
Project. It also contains all the Compositions we create in our 
current project. 

4. Timeline panel: It’s one of the main panels used for creating 
animations. Each composition created in the Project panel 
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has its own independent Timeline panel. That's where we can 
animate layer and effects properties, position layers in time, 
and change the layer blending modes.

5. Composition panel: The preview window and the main 
animation space where we work in when building an After 
Effects project.
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PROJECT 1: 
CREATING A TITLE 
ANIMATION

About this project
In this lesson, we’re going to focus on how to create a 
responsive title animation in After Effects to use in Premiere 
Pro. We're going to create the entire project from the very 
beginning. Let's get to it!

We’ll be covering the following topics:
 ҏ How to set up the project structure in After Effects
 ҏ How to import files
 ҏ How to use built-in animation tools
 ҏ How to create and animate text & shape layers
 ҏ How to write basic Expressions/Code
 ҏ How to create MoGRTS for Premiere Pro
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Exercise 1. Setting Up the After Effects Project
Having everything organized in the Project panel is very impor-
tant  and we're going to start by creating a folder structure to store 
compositions and images. 

Create New Folders
1. Click on the Create New Folder button at the bottom of the 

Project panel to create a new folder and name it 01_COMPS.

2. Deselect everything in the Project panel and click on the 
Create New Folder button to create another new 02_ASSETS 
folder.

Importing Images into the After Effects Project
3. Select 02_ASSETS f0lder and press CTRL/CMD + I or go to 

Application Window > File > Import > File... to import images 
into 02_ASSETS folder.

4. In the Import File window, select two images from the Rasters 
folder and click on Import.

 Ľ Rasters\AdobeStock_145208931.jpeg
 Ľ Rasters\AdobeStock_164991966.jpeg

Steps to create a New Composition
5. Select 01_COMPS f0lder and press CTRL/CMD + N or click on 

the Create a New Composition button at the bottom of the 
Project panel to create a new comp in the 01_COMPS folder.
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6. Make these changes in the Composition Settings window:

• Composition Name: 01_Title
• Preset: HDTV 1080 29.97
• Duration: 0;00;06;00

7. The final folder structure in the Project panel should look like 
the image below.

Exercise 2. Designing the Title
Now that we have our project structure created, the next step is to 
create the text & shape layers inside of the 01_Title composition.

Text & Shape Layer Set-Up
1. Go into 01_Title comp in the Project panel by double-clicking 

on it.
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2. Create a new text layer in the center of the Composition panel 
by double-clicking on the Type Tool located in the Toolbar 
panel.

3. Type MAIN TITLE GOES HERE as the source text of the text 
layer.

 

4. Select the text layer in the Composition panel and go into the 
Character panel to make the following changes.
• Font: Acumin Pro Condensed (Black)
• Size: 150
• Color: #F5EAD2
• Tracking: 20
• All Caps: ON

5. Select the text layer and go into the Paragraph panel to make 
the following changes.
• Set the Paragraph to Center Text

6. Select the text layer in the Timeline panel and press the 
ENTER key to rename it to Title 1.

7. Center the Anchor Point of the Title 1 layer by either pressing 
the CTRL/CMD +ALT/OPT + HOME key or by going to 
Application Window > Layer > Transform > Center Anchor 
Point in Layer Content.

8. Center the Title 1 layer in the Composition panel by either 
pressing the CTRL/CMD + HOME key or by going to 
Application Window > Layer > Transform > Center in View.

9. Deselect everything in the comp and go into the Toolbar 

 i 4. Character Panel Changes

 i 5. Paragraph Panel Changes
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panel and double-click on the Rectangle tool to create a 
rectangular shape layer in the 01_Title comp.

10. Select the new shape layer in the Timeline panel and place it 
under the Title 1 layer. Press the ENTER key to rename it to the 
Text Shape layer.

11. Select the Text Shape layer and change the Fill color of it 
to #EA4936 in the Toolbar panel. Make sure it doesn't have 
Stroke enabled.

12. Select the Text Shape layer in the Timeline panel and press 
the CTRL/CMD + F key to go into the Timeline Search Bar to 
search for the word Size.

13. Uncheck the Constrain Proportion of the Size property in the 
Timeline panel and change the value of it to 1500, 200.

14. Click on the Close icon in the Timeline Search Bar to get rid 
of the search feature.

15. Select the Title 1 layer in the Timeline panel and press CTRL/
CMD + D key to duplicate it. Move the Title 2 layer under the 
Title 1 layer.
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16. Select the Text 2 layer and make the following changes in the 
Character panel:
• Font: Acumin Pro Condensed (Semibold)
• Size: 100

17. Select the Title 2 layer and press the CTRL/CMD + ALT/OPT + 
HOME key to move the Anchor Point to the center of it.

18. Select the Title 2 layer and press the P key to display the 
Position property. Change the value of it to 960, 720.

19. Double-click on the Text 2 layer and change the source text of 
it to SUBTITLE GOES HERE.

20. Select the Text Shape layer and press the T key to display the 
Opacity property. Change the value of it to 70%.

21. Click on the Magnification Ratio Popup button in the 
Composition panel and set it to Fit.

22. Click on the Grid and Guide Options button in the 
Composition panel and set it to Proportional Grid.

 i 16. Character Panel Changes
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23. Select all 3 layers in the Composition panel.

24. Center all of the selected layers to the center of the 
Composition panel by using the Up/Down Arrow keys.

25. Click on the Grid and Guide Options > Proportional Grid to 
get rid of it in the Composition panel.

26. Create a new Shape layer by right-clicking on the Timeline 
panel and click on the New > Shape Layer. Name it Control.

  

27. Select all 3 layers in the Timeline panel and parent them to 
the Control layer using the Parent Pick-Whip tool.

Creating the Background Image Composition
28. Select the 01_COMPS folder in the Project panel and click on 

the Create a New Folder button. Rename it to preComps.

29. Select the preComps folder and click on the Create a 
Composition button to create a New Composition.
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30. Make these changes in the Composition Settings window:

• Composition Name: Background Image
• Preset: HDTV 1080 29.97
• Duration: 0;00;06;00

31. Go into the Background Image composition by double-
clicking on it in the Project panel.

32. Click and drag the AdobeStock_145208931.jpeg image into 
the Background Image comp from the Project panel.

33. Apply the Lumetri Color effect to the AdobeStock_145208931.
jpeg image by selecting it and going to Application Window > 
Effect > Color Correction > Lumetri Color.

34. Make the following changes to the Lumetri Color effect in the 
Effect Controls panel.
• Creative > Adjustments > Faded Film: 65.0
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• Creative > Adjustments > Split Toning > Shadow Tint: 
Blue Color (See the image below for the reference)

35. Click and drag the AdobeStock_164991966.jpeg image into 
the Background Image comp from the Project panel and 
place it above the AdobeStock_145208931.jpeg image.

36. Right-click on the AdobeStock_164991966.jpeg layer and 
click on Transform > Fit To Width to fit the image to the width 
of the current composition.

37. Change the AdobeStock_164991966.jpeg layer blending mode 
to Multiply.

 ҏ Important: If you don't see the layer blending mode option, 
you need to click on the Switches/Transfer Controls Menu 
button located at the bottom of the Timeline panel.

38. Deselect everything and go into the Toolbar panel. Double-
click on the Rectangular Tool button to create a new Shape 
layer and name it Vignette.

39. Apply the CC Vignette effect to the Vignette layer by right-
clicking on the layer and clicking on the Effect > Style > CC 
Vignette.
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40. Convert the Vignette layer to the Adjustment layer by clicking 
on the Adjustment layer checkbox.

 ҏ Important: If you don't see the Adjustment layer option, you 
need to click on the Switches/Transfer Controls Menu button 
located at the bottom of the Timeline panel.

41. Go into 01_Title composition and import the Background 
Image comp from the Project panel. Make sure it's the very 
last layer in the Timeline panel.

Exercise 3. Creating an Auto-Size Shape Layer
In this exercise, we're going to use the basic Expressions/Code to 
automatically adjust the width of our Text Shape layer to the width 
of the Title 1 layer.

Splitting 2D Values into Separate Single Slider Values
1. Apply the Slider Control effect to Text Shape layer by right-

clicking on the layer and clicking on the Effect > Expression 
Controls > Slider Control. 

 ҏ What is the Slider Control effect? Think of it as a custom 
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menu item we can link properties to. 
2. Select the Slider Control effect in the Effect Controls panel 

and duplicate it twice by pressing the CTRL/CMD + D key. 

3. Change the names and the values of each Slider Control 
effect to the following:

• X Size: 1500.00 px
• Y Size: 200.00 px
• Margin: 150.00 px

4. Select the Text Shape layer in the Timeline panel. Press the 
CTRL/CMD + F key to go into the Timeline Search Bar to 
search for the word Size.

5. Create an Expression for the Size property by holding down 
the ALT/OPT key and left-clicking on the Stopwatch.

6. Type [1500, 200] in the Expression Editor.

7. Highlight 1500 in the Expressing Editor and use the 
Expression Pick-Whip to point to the X Size slider control in 
the Effect Controls panel. From now on, the first value of the 
Size property will be the value of the X Size slider control.
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8. Let's do the same thing to the second value of the Size 
property. Highlight 200 in the Expressing Editor and use the 
Expression Pick-Whip to point to the Y Size slider control. 
From now on, the second value of the Size property will be the 
value of the Y Size slider control.

 ҏ The final line of code should look like the image below.

9. Click on the Close icon in the Timeline Search Bar to get rid 
of the search feature.

Auto Resize Set-Up
10. Select the Text Shape layer and press the E key to display the 

effects of the Text Shape layer in the Timeline panel.

11. Collapse the X Size and Margin groups by clicking on the 
arrows next to each group. Select the X Size and Margin 
sliders.

12. Solo selected sliders by press the S key twice (SS).

13. Deselect everything and create an expression for the X Size 
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property by holding down the ALT/OPT key and left-clicking 
on the Stopwatch.

14. Use an Expression Pick-Whip to write an expression 
referencing the Title 1 layer by Pick-Whipping to it. 

15. Let's continue writing the expression by adding the 
sourceRectAtTime().width method to the end of our code to 
get the width of the Title 1 layer.

 ҏ As you can see, our code is working well because the width 
of our Text Shape layer is the same as the width of our Title 1 
layer. However, we do need to add spacing to each side.

16. Let's add spacing to the Text Shape layer by adding the 
Margin slider value to our code. Insert the plus sign (+) to the 
end of our expression.

17. Next, use the Expression Pick-Whip to reference the Margin 
slider value at the end of our code by pointing to the Margin 
slider.



19SERGEI PROKHNEVSKIY | UKRAMEDIA.COM
How to Create Responsive Motion Graphics Templates for Premiere Pro

»  ProjeCt 1: CreAting A title AnimAtion

UKRAMEDIA.COM

 ҏ The final code should look like this:

Exercise 4. Animation
In this exercise, we're going to bring everything to life by animating 
our Text, Shape, and Background Image layers.

Text Animation
1. Let's get started by animating the Text 1 layer. Go into the Text 

1 layer and click on the Animate button > Position. 

2. Set the Position property value to 0, 150.

3. Go into Title 1 layer > Text > Animator 1 > Range Selector 1 > 
Advanced and make the following changes.

• Base On: Words
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• Shape: Ramp Up
• Ease High: 50%
• Ease Low: 80%

4. Create a keyframed animation for the Offset property located 
in Title 1 layer > Text > Animator 1 > Range Selector 1. Click 
on the Stopwatch to create the 1st keyframe.
◊ Set the 1st keyframe at 0:00:00:10 to -100
◊ Set the 2nd keyframe at 0:00:01:10 to 100

5. Select both keyframes and copy & paste them at 0:00:04:19.

6. Select pasted keyframes and right-click on one of them and 
click on the Keyframe Assistant > Time-Reverse Keyframes 
to reverse selected keyframes.

7. Take the Time Indicator in the Timeline panel to 0:00:02:00. 
Select the Title 1 layer and click on the Rectangle Tool in the 
Toolbar panel.
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8. Draw a mask on the Title 1 layer in the Composition panel 
similar to the mask in the image below.

9. Select & copy the Animator 1 group from the Title 1 layer by 
pressing the CTRL/CMD + C key.

10. Take the Time Indicator in the Timeline panel to 0:00:00:20.
 

11. Select the Title 2 layer and press the CTRL/CMD + V key to 
paste the Animator 1 group.

12. Select the Title 2 layer and press the U key to display all the 
keyframes of the Title 2 layer.

13. Take the Time Indicator to 0:00:04:09. Select the last two 
keyframes of the Title 2 layer and move them to the Time 
Indicator.
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14. While the Title 2 layer is still selected, search for the Position 
word in the Timeline Search Bar.

15. Change the Position value of the Animator 1 group to 150, 00.

16. Add an Opacity property to the Animator 1 group of the Title 
2 layer by clicking on the Add button > Property > Opacity.

17. Change the Opacity value of the Animator 1 group to 0%.

Shape Animation
18. Create a keyframed animation for the Scale property of the 

Text Shape layer. Select the Text Shape layer and press the S 
key to display the Scale property in the Timeline panel.
◊ Set the 1st keyframe at 0:00:00:05 to 0, 100%
◊ Set the 2nd keyframe at 0:00:01:05 to 100, 100%

19. Right-click on the 1st keyframe and go into the Keyframe 
Velocity window (Keyframe Assistant > Keyframe Velocity).
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20. In the Keyframe Velocity window, make the following change 
to the 1st keyframe:

21. Right-click on the 2nd keyframe and go into the Keyframe 
Velocity window (Keyframe Assistant > Keyframe Velocity).

22. In the Keyframe Velocity window, make the following change 
to the 2nd  keyframe:

23. Select both keyframes and copy & paste them to 0:00:04:24 in 
the Timeline panel. 
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24. Select pasted keyframes and right-click on one of them and 
click on Keyframe Assistant > Time-Reverse Keyframes to 
reverse the selected keyframes.

Background Image Animation
25. Select two layers, Text Shape and Background Image. Press 

the S key to display the Scale property of selected layers in the 
Timeline panel.

26. Select the Scale property of the Text Shape layer and copy it 
by pressing the CTRL/CMD + C key.

27. Take the Time Indicator in the Timeline panel to 0:00:00:0.
28. Select the Scale property of the Background Image layer and 

press the CTRL/CMD + V key to paste the keyframes.
29. Take the Time Indicator in the Timeline panel to 0:00:04:29.
30. Select the Background Image layer and press the CTRL/CMD 

+ V key to paste the keyframes.
31. Select the last two Scale keyframes of the Background Image 

layer and move them to where the first selected keyframe lines 
up with the Time Indicator.
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32. Select the Background Image layer and double-click on the 
Rectangle Tool in the Toolbar panel to create a new mask.

33. Click on the Grid and Guide options button at the bottom of 
the Composition panel to activate Proportional Grid.

34. Double-click on the Mask spline in the Composition panel to 
activate the Transform Handles. 

35. Click and drag the bottom center transform handle while 
holding down the CTRL/CMD key to resize the mask similar to 
the image below.

36. Select the Background Image layer in the Timeline panel and 
press the CTRL/CMD + D key to duplicate the layer.

37. Select the bottom of the Background Image layer and press the 
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U key to display all keyframes.

38. Offset the first two keyframes by moving them to 0:00:00:05

39. Offset the last two keyframes by moving them to 0:00:04:24

40. Resize the mask of the bottom Background Image layer 
similar to what we did before.

41. Select the bottom Background Image layer in the Timeline 
panel and press the CTRL/CMD + D key to duplicate the layer.

42. Select the bottom Background Image layer and press the U key 
to display all keyframes.

43. Offset the first two keyframes by moving them to 0:00:00:10
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44. Offset the last two keyframes by moving them to 0:00:04:19

45. Select the bottom Background Image layer in the Timeline 
panel and press the M key to display the Mask 1 in the 
Timeline panel. Select the Mask 1 and delete it by pressing 
the DELETE key.

46. Go into the Background Image composition and select the 
AdobeStock_145208931.jpeg layer.

47. Press the S key to display the Scale property and create the 
following keyframes:
◊ Set the 1st keyframe at 0:00:00:00 to 60, 60%
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◊ Set the 2nd keyframe at 0:00:05:29 to 70, 70%
48. Select the AdobeStock_145208931.jpeg layer. Press the P 

key to display the Position property and create the following 
keyframes:
◊ Set the 1st keyframe at 0:00:00:00 to 960, 320
◊ Set the 2nd keyframe at 0:00:05:29 to 960, 420

Exercise 5. Creating a Title MoGRT
In this exercise, we're going convert the 01_Title comp into a Motion 
Graphics Template (MoGRT) to use in Premiere Pro without ever 
opening up After Effects.

Creating a Title MoGRT in After Effects
1. Go into 01_Title comp, select the Title 1 and the Title 2 layer 

and search for Source Text in the Timeline Search Bar.  

2. Right-click on the Timeline panel and click on the Open in 
Essential Graphics.

3. In the Essential Graphics panel, change the name to 01_Title 
and click on the Set Poster Time button to create a thumbnail. 
NOTE: The MoGRT thumbnail is created based on the location 
of the Time Indicator in the Timeline Panel.
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4. Click and drag the Source Text property of the Title 1 layer 
into the Essential Graphics panel and rename it to Title 1.

5. Click and drag the Source Text property of the Title 2 layer 
into the Essential Graphics panel and rename it to Title 2.

6. Once we're done creating the menu of all the properties we 
want for the editors to adjust in Premiere Pro, the next step 
is to export the MoGRT by clicking on the Export Motion 
Graphics Template button.
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PROJECT 2: 
CREATING A LOWER 
THIRD ANIMATION

About this project
Almost every video project requires a lower third graphic to help 
us tell a better story. That's why we're going to focus on how to 
quickly create a lower third graphic using the elements we have 
already created.

Exercise 1. Designing the Lower Third
In this exercise, we're going to use 01_Title comp to create a lower 
third graphic for Premiere Pro.

Creating a Lower Third Composition
1. Select the 01_Title comp in the Project panel and press the 

CTRL/CMD + D key to duplicate it. Name it 02_Lower Third.
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2. Go into the 02_Lower Third comp and delete all 3 
Background Image layers.

Text and Shape Layer Changes
3. Select the Title 1 layer and change the Font Size to 100 px.
4. Center the Anchor Point of the Title 1 layer by pressing the 

CTRL/CMD + ALT/OPT + HOME key.
5. Select the Title 2 layer and change the Font Size to 50 px.
6. Center the Anchor Point of Title 2 layer by pressing the CTRL/

CMD + ALT/OPT + HOME key.
7. Change the Y Size slider value of the Text Shape layer in the 

Effect Controls panel to 150 px.

8. Position both text layers in the center of the Text Shape layer 
by changing the Position of the Title 1 layer to 0.0, -80.0 and 
Title 2 layer to 0.0, -15.0.
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Stroke Animation
9. Select the Text Shape layer and press the CTRL/CMD + D key 

to duplicate it. Name it Stroke.

10. Select the Stroke layer and press the S key to display the Scale 
property in the Timeline panel.

11. Click on the Scale property to select all keyframes.

12. Press the DELETE key to delete all keyframes.

13. Set the Scale property of the Stroke layer to 100.0, 100.0%.
14. Select the Stroke layer and click on the Fill Options button in 

the Toolbar panel to change the Fill Options to None. 

15. Select the Stroke layer and click on the Stroke Options button 
in the Toolbar panel and change the Stroke Options to Solid 
Color. 

16. Select the Stroke layer and click on the Stroke Width button 
in the Toolbar panel and change the Stroke Width to 6 px. 

17. Select the Stroke layer and click on the Stroke Color button in 
the Toolbar panel and change the Stroke Color to # F5EAD2.
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18. Go into the Stroke layer and click on the Add button > Trim 
Paths to add the Trim Paths action for the Stroke layer.

19. Create a keyframed animation for the End property located in 
Stroke layer > Contents > Trim Paths 1.
◊ Set the 1st keyframe at 0:00:00:00 to 0%
◊ Set the 2nd keyframe t 0:00:01:00 to 100%

20. Right-click on the 1st keyframe and go into the Keyframe 
Velocity window to make the following changes. (Keyframe 
Assistant > Keyframe Velocity)

21. Right-click on the 2nd keyframe  and go into the Keyframe 
Velocity window to make the following changes. (Keyframe 
Assistant > Keyframe Velocity)



34SERGEI PROKHNEVSKIY | UKRAMEDIA.COM
How to Create Responsive Motion Graphics Templates for Premiere Pro

»  ProjeCt 2: CreAting A lower third AnimAtion

UKRAMEDIA.COM

22. Select both keyframes and copy & paste them at 0:00:04:29.

23. Select pasted keyframes and right-click on one of them and 
click on the Keyframe Assistant > Time-Reverse Keyframes 
to reverse the selected keyframes.

24. Select and copy the first two keyframes from the End property. 
Select the Start property and paste the copied keyframes at 
0:00:00:10. 

25. Select and copy the last two keyframes of the End property. 
Select the Start property and paste the copied keyframes at 
0:00:04:19. 
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Exercise 2. Setting Up the Lower Third Position
In this exercise, we're going use the expressions/code to lock the 
position of the lower third to the bottom left corner.

1. Select the Control layer and press the P key to display the 
Position property. Right-click on the Position property and 
click on the Separate Dimensions.

2. Set the X Position to 150 and the Y Position to 970.

3. Create an expression for the X Position property by holding 
down the ALT/OPT key and clicking on the Stopwatch.

4. Type value + in the Expression Editor to reference the current 
Position value.

5. Go to the end of the code and use the Expression Pick-Whip 
tool to reference the Text Shape layer by pick-whipping to the 
Text Shape layer.

6. Next, add sourceRectAtTime().width/2 to the end of the code. 
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7. The final result of this code will lock the position of the lower 
third graphic at the bottom left corner of our composition 
regardless of what we type.
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Exercise 3. Creating a Lower Third MoGRT
In this exercise, we're going convert our After Effects project into 
a Motion Graphics Template (MoGRT) to use in Premiere Pro 
without ever opening up After Effects.

1. Right-click on the Timeline panel of the 02_Lower Third 
comp and click on the Open in Essential Graphics.

2. In the Essential Graphics panel, change the name to 
02_Lower Third and click on the Set Poster Time button to 
create a thumbnail.

3. Once we're done creating the menu, the next step is to export 
the MoGRT by clicking on the Export Motion Graphics 
Template button.
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THANK YOU!
Thank you!
Thank you for choosing this lesson! I hope you learned something 
new that will inspire you to create beautiful things.

SERGEI PROKHNEVSKIY
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